Back to overview
Degraded
Withdrawal page down
Mar 05 at 04:31pm HST
Affected services
beta.bloxgrow.best
Resolved
Mar 06 at 05:21pm HST
We have identified the root cause of the issue. All users should be able to access the withdrawal page now. Thanks for your patience!
Affected services
beta.bloxgrow.best
Created
Mar 05 at 04:31pm HST
The withdrawal page is down for all users, the withdrawal system is not affected by this incident. We are not aware when this error started occurring.
We are currently working on a solution, thank you for your patience.
Affected services
beta.bloxgrow.best