Back to overview
Downtime
Dashboard unavailable
Jan 22 at 01:29pm HST
Affected services
beta.bloxgrow.best
Resolved
Jan 23 at 07:49am HST
We have identified the root cause of all issues, the earn page should be stable and all features are operational. Thank you for your patience!
Affected services
beta.bloxgrow.best
Updated
Jan 22 at 07:20pm HST
We’ve successfully identified and resolved the root cause of the issue, and users can now log in to their accounts without any problems. However, the Earn page is still not functioning as expected.
Affected services
beta.bloxgrow.best
Created
Jan 22 at 01:29pm HST
Dashboard is currently unavailable to all users. Please stay on hold while we resolve this issue.
Affected services
beta.bloxgrow.best